aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-24 22:34:25 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-24 22:34:25 +0200
commite7479210fabe056f4ef7be37ef34d5f2ba08a5c1 (patch)
treee931ac33032620e0fb739c25105bb2881fddab85 /data/CMakeLists.txt
parent0d576ab2048506da7d103401db6ddb9c174ec058 (diff)
downloadayatana-indicator-sound-e7479210fabe056f4ef7be37ef34d5f2ba08a5c1.tar.gz
ayatana-indicator-sound-e7479210fabe056f4ef7be37ef34d5f2ba08a5c1.tar.bz2
ayatana-indicator-sound-e7479210fabe056f4ef7be37ef34d5f2ba08a5c1.zip
Revert "Remove old autostart files."
This reverts commit 088782b986aac9e6cc22deae1827c4754f960aef.
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 69a5095..8a1dd16 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -71,6 +71,47 @@ install(
)
###########################
+# XDG Autostart
+###########################
+
+set(
+ INDICATOR_SOUND_XDG_AUTOSTART
+ "${CMAKE_CURRENT_BINARY_DIR}/indicator-sound.desktop"
+)
+
+configure_file(
+ "indicator-sound.desktop.in"
+ ${INDICATOR_SOUND_XDG_AUTOSTART}
+ @ONLY
+)
+
+install(
+ FILES "${INDICATOR_SOUND_XDG_AUTOSTART}"
+ DESTINATION "/etc/xdg/autostart"
+)
+
+###########################
+# Upstart XDG Autostart Override
+###########################
+
+set(
+ INDICATOR_SOUND_UPSTART_XDG_AUTOSTART
+ "${CMAKE_CURRENT_BINARY_DIR}/indicator-sound.upstart.desktop"
+)
+
+configure_file(
+ "indicator-sound.upstart.desktop.in"
+ ${INDICATOR_SOUND_UPSTART_XDG_AUTOSTART}
+ @ONLY
+)
+
+install(
+ FILES "${INDICATOR_SOUND_UPSTART_XDG_AUTOSTART}"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/upstart/xdg/autostart"
+ RENAME "indicator-sound.desktop"
+)
+
+###########################
# GSettings
###########################