aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-03-24 15:01:35 +0000
committerCI bot <ps-jenkins@lists.canonical.com>2014-03-24 15:01:35 +0000
commitf2e935d91e34368e38f5419af844e2fd705164b7 (patch)
tree55127d00c2d4f04b6a0431080677304c9afbc906 /data/CMakeLists.txt
parent87fca85fbcb5fe94bcbbf52e1ce828372c5cf938 (diff)
parente7df1393fb23d3478f4dfd29a8244b3d8d873e91 (diff)
downloadayatana-indicator-sound-f2e935d91e34368e38f5419af844e2fd705164b7.tar.gz
ayatana-indicator-sound-f2e935d91e34368e38f5419af844e2fd705164b7.tar.bz2
ayatana-indicator-sound-f2e935d91e34368e38f5419af844e2fd705164b7.zip
Synchronize process management across indicators
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 565e652..80046f7 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -57,6 +57,27 @@ install(
)
###########################
+# Upstart XDG Autostart Override
+###########################
+
+set(
+ INDICATOR_SOUND_UPSTART_XDG_AUTOSTART
+ "${CMAKE_CURRENT_BINARY_DIR}/indicator-sound.upstart.desktop"
+)
+
+configure_file(
+ "indicator-sound.upstart.desktop.in"
+ ${INDICATOR_SOUND_UPSTART_XDG_AUTOSTART}
+ @ONLY
+)
+
+install(
+ FILES "${INDICATOR_SOUND_UPSTART_XDG_AUTOSTART}"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/upstart/xdg/autostart"
+ RENAME "indicator-sound.desktop"
+)
+
+###########################
# GSettings
###########################