aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/disable_Werror.patch
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2012-01-05 10:29:36 +0100
committerPackage Import Robot <package-import@ubuntu.com>2012-01-05 10:29:36 +0100
commite8673be2a2776278cf919c9a70d75668097b3da3 (patch)
treedf510259376da0cec9db050773d89743efe5e7a9 /debian/patches/disable_Werror.patch
parent47dfa221d14383b68820049af9e612e96cee3d4a (diff)
downloadayatana-indicator-sound-e8673be2a2776278cf919c9a70d75668097b3da3.tar.gz
ayatana-indicator-sound-e8673be2a2776278cf919c9a70d75668097b3da3.tar.bz2
ayatana-indicator-sound-e8673be2a2776278cf919c9a70d75668097b3da3.zip
* Add lazy_init.patch: Avoid spawning notification daemon right at startup,
instead initialize it lazily when actually doing a notification. Improves boot speed. (LP: #912150) * Add disable_Werror.patch: Build without -Werror, to avoid build failure due to deprecated declarations. (LP: #912160)
Diffstat (limited to 'debian/patches/disable_Werror.patch')
-rw-r--r--debian/patches/disable_Werror.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/debian/patches/disable_Werror.patch b/debian/patches/disable_Werror.patch
new file mode 100644
index 0000000..f71eb33
--- /dev/null
+++ b/debian/patches/disable_Werror.patch
@@ -0,0 +1,30 @@
+Description: Build without -Werror, to avoid build failure due to deprecated declarations.
+Author: Martin Pitt <martin.pitt@ubuntu.com>
+Bug: https://launchpad.net/bugs/912160
+
+Index: indicator-sound-0.8.0.0/src/Makefile.in
+===================================================================
+--- indicator-sound-0.8.0.0.orig/src/Makefile.in 2011-12-01 19:33:43.000000000 +0100
++++ indicator-sound-0.8.0.0/src/Makefile.in 2012-01-05 09:43:38.000000000 +0100
+@@ -357,7 +357,7 @@
+ gen-sound-service.xml.c \
+ dbus-shared-names.h
+
+-libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror -DG_LOG_DOMAIN=\"Indicator-Sound\"
++libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -DG_LOG_DOMAIN=\"Indicator-Sound\"
+ libsoundmenu_la_LIBADD = $(APPLET_LIBS) -lm
+ libsoundmenu_la_LDFLAGS = -module -avoid-version
+
+Index: indicator-sound-0.8.0.0/src/Makefile.am
+===================================================================
+--- indicator-sound-0.8.0.0.orig/src/Makefile.am 2011-12-01 15:56:10.000000000 +0100
++++ indicator-sound-0.8.0.0/src/Makefile.am 2012-01-05 09:43:52.670645999 +0100
+@@ -28,7 +28,7 @@
+ gen-sound-service.xml.c \
+ dbus-shared-names.h
+
+-libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror -DG_LOG_DOMAIN=\"Indicator-Sound\"
++libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -DG_LOG_DOMAIN=\"Indicator-Sound\"
+ libsoundmenu_la_LIBADD = $(APPLET_LIBS) -lm
+ libsoundmenu_la_LDFLAGS = -module -avoid-version
+