aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-06-28 10:50:09 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-06-28 10:50:09 -0400
commit0db14c2008893a3fec9182b28947ff8efbf6cf7d (patch)
treec340ac55ae65a421b2b0dc58b8695dada1441267 /debian/rules
parent2ada6ebcaa4d92f1e1374c8ad7564c720e5930b2 (diff)
parentf51439abe6747ef022989a2aa6262481dc6c771d (diff)
downloadayatana-indicator-sound-0db14c2008893a3fec9182b28947ff8efbf6cf7d.tar.gz
ayatana-indicator-sound-0db14c2008893a3fec9182b28947ff8efbf6cf7d.tar.bz2
ayatana-indicator-sound-0db14c2008893a3fec9182b28947ff8efbf6cf7d.zip
Merged
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 14 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index d778ba1..7950ed1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,20 +1,23 @@
#!/usr/bin/make -f
+DEB_BUILDDIR = build
+DEB_MAKE_FLAVORS = gtk2 gtk3
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
-include /usr/share/cdbs/1/rules/autoreconf.mk
-# List any files which are not installed
-include /usr/share/cdbs/1/rules/utils.mk
-common-binary-post-install-arch:: list-missing
+DEB_MAKE_DESTDIRSKEL = $(CURDIR)/debian/tmp/@FLAVOR@
+DEB_DESTDIR = $(CURDIR)/debian/tmp/$(cdbs_make_curflavor)/
-LDFLAGS += -Wl,-z,defs -Wl,-O1 -Wl,--as-needed
+DEB_CONFIGURE_FLAGS_gtk2 = --with-gtk=2
+DEB_CONFIGURE_FLAGS_gtk3 = --with-gtk=3
+DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
-DEB_DH_MAKESHLIBS_ARGS = -Xusr/lib/indicators
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-binary-install/indicator-sound::
- # remove .a/.la clutter
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.a
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.la
+debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)
+debian/stamp-autotools/gtk3: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk3)
+common-install-arch::
+ find debian/tmp -name \*.la -delete
+ find debian/tmp -name \*.a -delete