aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorunknown <allanlesage@gmail.com>2012-10-26 16:32:54 +0200
committerunknown <allanlesage@gmail.com>2012-10-26 16:32:54 +0200
commit89211f0b3c8d438bd4d4cba9f9f451637e6285fd (patch)
tree41faf8fec7dd8de00f1f96ea7f3717561665f3f1 /debian/rules
parentb6da5f103c9ebac36f61ada84c8bdf1ab98d30ee (diff)
downloadayatana-indicator-sound-89211f0b3c8d438bd4d4cba9f9f451637e6285fd.tar.gz
ayatana-indicator-sound-89211f0b3c8d438bd4d4cba9f9f451637e6285fd.tar.bz2
ayatana-indicator-sound-89211f0b3c8d438bd4d4cba9f9f451637e6285fd.zip
* debian/control: update to debhelper 9.0
* debian/rules: change to debhelper 9.0
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 6 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 4ffb502..400a07b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,10 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/autoreconf.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/gnome.mk
-DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
+%:
+ dh $@ --with translations,autoreconf
-CFLAGS += -Wno-error=deprecated-declarations
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-
-common-install-arch::
- find debian/indicator-sound -name \*.la -delete
+override_dh_install:
+ find debian/indicator-sound/usr/lib -name *.la -delete
+ find debian/indicator-sound/usr/lib -name *.a -delete
+ dh_install --fail-missing