aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-08-19 20:58:43 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-08-19 20:58:43 +0200
commitb6fd253d62029c91a0664b758ae209643ad46461 (patch)
treeb6d98e0bf1f9b41ae00eca582a4d09957c88f903 /debian
parent4d8f2ede344d4a91da5994774b1925ad49e13149 (diff)
downloadayatana-indicator-sound-b6fd253d62029c91a0664b758ae209643ad46461.tar.gz
ayatana-indicator-sound-b6fd253d62029c91a0664b758ae209643ad46461.tar.bz2
ayatana-indicator-sound-b6fd253d62029c91a0664b758ae209643ad46461.zip
debian/rules: Disable unit tests at build time (this needs to be reintroduced at some later point of time).
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 276a29d..5a01b3c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+NULL =
+
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
%:
@@ -8,7 +10,9 @@ export DPKG_GENSYMBOLS_CHECK_LEVEL=4
override_dh_auto_configure:
# Debian defines CMAKE_INSTALL_LOCALSTATEDIR as /usr/var, which is wrong.
# So until Debian bug 719148 is fixed, do it ourselves.
- dh_auto_configure -- -DCMAKE_INSTALL_LOCALSTATEDIR="/var"
+ dh_auto_configure -- -DCMAKE_INSTALL_LOCALSTATEDIR="/var" \
+ -Denable_tests=off \
+ $(NULL)
override_dh_install:
dh_install --fail-missing