aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 20:38:34 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 20:38:34 +0100
commitf31a081b02fa1cc3952d5efa31770ac5dd5a94ce (patch)
tree008b9cde5b63686f4c9534f4a2fe497d4e00a81c /debian
parent3a0680fb93da777723b508929437ca655f0f3faf (diff)
downloadayatana-indicator-sound-f31a081b02fa1cc3952d5efa31770ac5dd5a94ce.tar.gz
ayatana-indicator-sound-f31a081b02fa1cc3952d5efa31770ac5dd5a94ce.tar.bz2
ayatana-indicator-sound-f31a081b02fa1cc3952d5efa31770ac5dd5a94ce.zip
debian/{control,postinst}: Recompile GSettings schemas at post installation.
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/postinst40
2 files changed, 41 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 440721c..f704b48 100644
--- a/debian/control
+++ b/debian/control
@@ -48,6 +48,7 @@ Depends: ${shlibs:Depends},
${misc:Depends},
pulseaudio,
ayatana-indicator-common,
+ glib2.0-bin,
Recommends: unity-control-center | gnome-control-center | pavucontrol | mate-media,
accountsservice,
Suggests: ayatana-greeter-session-broadcast,
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..6ae772c
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,40 @@
+#!/bin/sh
+# postinst script for ayatana-indicator-sound
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ configure)
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0