aboutsummaryrefslogtreecommitdiff
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorRodney Dawes <rodney.dawes@canonical.com>2017-02-07 17:04:35 -0500
committerRodney Dawes <rodney.dawes@canonical.com>2017-02-07 17:04:35 -0500
commit6f122ae1b2b8aeb052a90201f1dda8a8c4ba434e (patch)
treeeb9abea72db23c45e0bb46437cfe707d9f4feeb7 /po/CMakeLists.txt
parent47be95adcf9600979cbe0b3bb3269a6b9041efb2 (diff)
downloadayatana-indicator-sound-6f122ae1b2b8aeb052a90201f1dda8a8c4ba434e.tar.gz
ayatana-indicator-sound-6f122ae1b2b8aeb052a90201f1dda8a8c4ba434e.tar.bz2
ayatana-indicator-sound-6f122ae1b2b8aeb052a90201f1dda8a8c4ba434e.zip
Use intltool support from cmake-extras.
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..e78a9df
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,12 @@
+find_package(Intltool REQUIRED)
+
+intltool_update_potfile(
+ KEYWORDS "_" "_:1,2" "N_" "N_:1,2"
+ GETTEXT_PACKAGE ${GETTEXT_PACKAGE}
+ COPYRIGHT_HOLDER "Canonical Ltd."
+)
+
+intltool_install_translations(
+ ALL
+ GETTEXT_PACKAGE ${GETTEXT_PACKAGE}
+)