aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2011-08-08 17:51:23 +0100
committerConor Curran <conor.curran@canonical.com>2011-08-08 17:51:23 +0100
commit4300a124d6959f8bfad9393530de587fefe828be (patch)
tree0e3b2e3d6b96e0473a7ccc729b133aa3ad89217c /src/Makefile.am
parentd0727964e78fd5174402e4732731ad11ad0d7ef3 (diff)
parentc60b7f972eb8faa1b06366dfebdb4a220d565f1e (diff)
downloadayatana-indicator-sound-4300a124d6959f8bfad9393530de587fefe828be.tar.gz
ayatana-indicator-sound-4300a124d6959f8bfad9393530de587fefe828be.tar.bz2
ayatana-indicator-sound-4300a124d6959f8bfad9393530de587fefe828be.zip
added missing marshaller and merged in tip to keep things up to date for oneiric
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6917aee..2381429 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,6 +18,8 @@ libsoundmenu_la_SOURCES = \
transport-widget.h \
metadata-widget.c \
metadata-widget.h \
+ mute-widget.c \
+ mute-widget.h \
volume-widget.c \
volume-widget.h \
voip-input-widget.c \
@@ -125,11 +127,11 @@ DBUS_SPECS = \
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
+ @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@
gen-%.xml.c: %.xml
@echo "Building $@ from $<"
- @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
+ @echo "const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<)))) = " > $@
@sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
@echo ";" >> $@