aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-01-27 13:21:02 +0000
committerConor Curran <conor.curran@canonical.com>2010-01-27 13:21:02 +0000
commit5a86d06d8019cd9a827f69839d23268a2a6ebc51 (patch)
tree4c76cffbc028fbe585199f794e99c5cc13fda83f /src/Makefile.am
parentef9c492c6203cbc1a72aca7c48eb3ada324f2581 (diff)
downloadayatana-indicator-sound-5a86d06d8019cd9a827f69839d23268a2a6ebc51.tar.gz
ayatana-indicator-sound-5a86d06d8019cd9a827f69839d23268a2a6ebc51.tar.bz2
ayatana-indicator-sound-5a86d06d8019cd9a827f69839d23268a2a6ebc51.zip
copied contents from lp:~cjcurran/wasilla/soundmenu without the noise
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am84
1 files changed, 84 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..bd9b2ad
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,84 @@
+libexec_PROGRAMS = indicator-sound-service
+
+###################
+# Indicator Stuff
+###################
+
+soundmenulibdir = $(INDICATORDIR)
+soundmenulib_LTLIBRARIES = libsoundmenu.la
+libsoundmenu_la_SOURCES = \
+ common-defs.h \
+ indicator-sound.c \
+ dbus-shared-names.h \
+ sound-service-client.h \
+ sound-service-marshal.c \
+ sound-service-marshal.h
+
+libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror
+libsoundmenu_la_LIBADD = $(APPLET_LIBS)
+libsoundmenu_la_LDFLAGS = -module -avoid-version
+
+checkxml: $(srcdir)/sound-service.xml
+ @xmllint -valid -noout $<
+ @echo $< checks out ok
+
+sound-service-client.h: $(srcdir)/sound-service.xml
+ dbus-binding-tool \
+ --prefix=_sound_service_client \
+ --mode=glib-client \
+ --output=sound-service-client.h \
+ $(srcdir)/sound-service.xml
+
+sound-service-server.h: $(srcdir)/sound-service.xml
+ dbus-binding-tool \
+ --prefix=_sound_service_server \
+ --mode=glib-server \
+ --output=sound-service-server.h \
+ $(srcdir)/sound-service.xml
+
+sound-service-marshal.h: $(srcdir)/sound-service.list
+ glib-genmarshal --header \
+ --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
+ > sound-service-marshal.h
+
+sound-service-marshal.c: $(srcdir)/sound-service.list
+ glib-genmarshal --body \
+ --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
+ > sound-service-marshal.c
+
+
+#################
+# Session Stuff
+#################
+indicator_sound_service_SOURCES = \
+ common-defs.h \
+ sound-service.h \
+ sound-service.c \
+ sound-service-dbus.h \
+ sound-service-dbus.c \
+ sound-service-server.h \
+ sound-service-marshal.c \
+ sound-service-marshal.h
+indicator_sound_service_CFLAGS = $(SOUNDSERVICE_CFLAGS) $(GCONF_CFLAGS) -DLIBEXECDIR=\"$(libexecdir)\" -Wall -Werror
+indicator_sound_service_LDADD = $(SOUNDSERVICE_LIBS) $(GCONF_LIBS)
+
+###############
+# Other Stuff
+###############
+BUILT_SOURCES = \
+ sound-service-client.h \
+ sound-service-server.h \
+ sound-service-marshal.h \
+ sound-service-marshal.c
+
+EXTRA_DIST = \
+ sound-service.xml \
+ sound-service.list
+
+CLEANFILES = \
+ $(BUILT_SOURCES)
+
+
+
+
+