aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2010-03-11 19:00:38 +0100
committerSebastien Bacher <seb128@ubuntu.com>2010-03-11 19:00:38 +0100
commit6df1024fe1a7cbfb9f6ba38cfe33a04889c2d40f (patch)
tree6c9e280e2289b7340981dbdcf21ee3b4982d832e /src/Makefile.am
parent39cc953dc802c485d690fbbac77eaa6364818680 (diff)
parentb4dfb37242eb867798f778a80d5ece48a568630b (diff)
downloadayatana-indicator-sound-6df1024fe1a7cbfb9f6ba38cfe33a04889c2d40f.tar.gz
ayatana-indicator-sound-6df1024fe1a7cbfb9f6ba38cfe33a04889c2d40f.tar.bz2
ayatana-indicator-sound-6df1024fe1a7cbfb9f6ba38cfe33a04889c2d40f.zip
Import upstream version 0.1.3
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 5 insertions, 16 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 543ec58..73bb259 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,11 +8,10 @@ soundmenulibdir = $(INDICATORDIR)
soundmenulib_LTLIBRARIES = libsoundmenu.la
libsoundmenu_la_SOURCES = \
common-defs.h \
+ indicator-sound.h \
indicator-sound.c \
dbus-shared-names.h \
- sound-service-client.h \
- sound-service-marshal.c \
- sound-service-marshal.h
+ sound-service-client.h
libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror
libsoundmenu_la_LIBADD = $(APPLET_LIBS)
@@ -29,16 +28,6 @@ sound-service-client.h: $(srcdir)/sound-service.xml
--output=sound-service-client.h \
$(srcdir)/sound-service.xml
-sound-service-marshal.h: $(srcdir)/sound-service.list
- glib-genmarshal --header \
- --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
- > sound-service-marshal.h
-
-sound-service-marshal.c: $(srcdir)/sound-service.list
- glib-genmarshal --body \
- --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
- > sound-service-marshal.c
-
#################
# Session Stuff
@@ -47,6 +36,8 @@ indicator_sound_service_SOURCES = \
common-defs.h \
sound-service.h \
sound-service.c \
+ dbus-menu-manager.c \
+ dbus-menu-manager.h \
pulse-manager.h \
pulse-manager.c \
sound-service-dbus.h \
@@ -71,9 +62,7 @@ sound-service-server.h: $(srcdir)/sound-service.xml
###############
BUILT_SOURCES = \
sound-service-client.h \
- sound-service-server.h \
- sound-service-marshal.h \
- sound-service-marshal.c
+ sound-service-server.h
EXTRA_DIST = \
sound-service.xml \