aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-03-05 10:38:57 +0000
committerConor Curran <conor.curran@canonical.com>2010-03-05 10:38:57 +0000
commit8d392c8f315f18c1ebc52850141b103897e2eea2 (patch)
tree9b2d839692f3e1668a1cacec9f4eecec5b6542a3 /src/Makefile.am
parent378c3c3f79aae564090593af6c6ce6abdb3c541a (diff)
downloadayatana-indicator-sound-8d392c8f315f18c1ebc52850141b103897e2eea2.tar.gz
ayatana-indicator-sound-8d392c8f315f18c1ebc52850141b103897e2eea2.tar.bz2
ayatana-indicator-sound-8d392c8f315f18c1ebc52850141b103897e2eea2.zip
blocking event now being registered, removed unneccessary marshaller
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 2 insertions, 16 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 40a8fdd..73bb259 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,9 +11,7 @@ libsoundmenu_la_SOURCES = \
indicator-sound.h \
indicator-sound.c \
dbus-shared-names.h \
- sound-service-client.h \
- sound-service-marshal.c \
- sound-service-marshal.h
+ sound-service-client.h
libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror
libsoundmenu_la_LIBADD = $(APPLET_LIBS)
@@ -30,16 +28,6 @@ sound-service-client.h: $(srcdir)/sound-service.xml
--output=sound-service-client.h \
$(srcdir)/sound-service.xml
-sound-service-marshal.h: $(srcdir)/sound-service.list
- glib-genmarshal --header \
- --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
- > sound-service-marshal.h
-
-sound-service-marshal.c: $(srcdir)/sound-service.list
- glib-genmarshal --body \
- --prefix=_sound_service_marshal $(srcdir)/sound-service.list \
- > sound-service-marshal.c
-
#################
# Session Stuff
@@ -74,9 +62,7 @@ sound-service-server.h: $(srcdir)/sound-service.xml
###############
BUILT_SOURCES = \
sound-service-client.h \
- sound-service-server.h \
- sound-service-marshal.h \
- sound-service-marshal.c
+ sound-service-server.h
EXTRA_DIST = \
sound-service.xml \