aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-03-22 16:24:06 -0400
committerLars Uebernickel <lars.uebernickel@canonical.com>2013-03-22 16:24:06 -0400
commit92c98f341c6b5600d4b5fae8753326c866e40860 (patch)
tree6335f180e06be2f1b4c7dc7f1a6ac907e35d46cc /src/Makefile.am
parentea30986e03e54ee650a1cca610904de9f4d0f745 (diff)
downloadayatana-indicator-sound-92c98f341c6b5600d4b5fae8753326c866e40860.tar.gz
ayatana-indicator-sound-92c98f341c6b5600d4b5fae8753326c866e40860.tar.bz2
ayatana-indicator-sound-92c98f341c6b5600d4b5fae8753326c866e40860.zip
Add service that adheres to the new indicator protocol
This is the one that gets built now. It doesn't do anything interesting yet, though.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a56f82a..39ec6bf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,6 +17,8 @@ glib_marshal_prefix = _sound_service_marshal
# Sound service vala
#####################
music_bridge_VALASOURCES = \
+ service.vala \
+ main.vala \
music-player-bridge.vala \
transport-menu-item.vala \
specific-items-manager.vala \
@@ -44,7 +46,9 @@ music_bridge_VALAFLAGS = \
--pkg gio-2.0 \
--pkg gio-unix-2.0 \
--pkg gdk-pixbuf-2.0 \
- --pkg libxml-2.0
+ --pkg libxml-2.0 \
+ --pkg libpulse \
+ --target-glib=2.36
$(MAINTAINER_VALAFLAGS)
@@ -60,8 +64,6 @@ music_bridge_vala.stamp $(music_bridge_APIFILES): $(music_bridge_VALASOURCES)
###############################
indicator_sound_service_SOURCES = \
common-defs.h \
- sound-service.h \
- sound-service.c \
sound-state.c \
sound-state.h \
pulseaudio-mgr.h \