aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-08-10 12:58:49 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-08-10 12:58:49 -0400
commit9cae3218511419b9bb0bddd896dd8b13fac76a50 (patch)
tree61a59ad4047068ab761c592717a2993872044bee /src/Makefile.am
parent6a7027eea846bcc0c0a249f7e93fdadb407bed71 (diff)
parent4f6158a1040258efb1403d6baf246b605dfa76cb (diff)
downloadayatana-indicator-sound-9cae3218511419b9bb0bddd896dd8b13fac76a50.tar.gz
ayatana-indicator-sound-9cae3218511419b9bb0bddd896dd8b13fac76a50.tar.bz2
ayatana-indicator-sound-9cae3218511419b9bb0bddd896dd8b13fac76a50.zip
* New upstream release.
- Don't allow starting programs via the greeter indicators (LP: #811853) - support libunity's Track and Player specific items (LP: #824050)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 60c7249..2381429 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -32,6 +32,7 @@ libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror -DG_LOG_DOMAIN=\"Indicat
libsoundmenu_la_LIBADD = $(APPLET_LIBS)
libsoundmenu_la_LDFLAGS = -module -avoid-version
+
checkxml: $(srcdir)/sound-service.xml
@xmllint -valid -noout $<
@echo $< checks out ok
@@ -41,6 +42,9 @@ checkxml: $(srcdir)/sound-service.xml
# Sound Service
####################################################################
+glib_marshal_list = sound-service-marshal.list
+glib_marshal_prefix = _sound_service_marshal
+
#####################
# Sound service vala
@@ -48,6 +52,7 @@ checkxml: $(srcdir)/sound-service.xml
music_bridge_VALASOURCES = \
music-player-bridge.vala \
transport-menu-item.vala \
+ specific-items-manager.vala \
metadata-menu-item.vala \
player-controller.vala \
mpris2-interfaces.vala \
@@ -107,6 +112,8 @@ indicator_sound_service_SOURCES = \
mute-menu-item.c \
gen-sound-service.xml.h \
gen-sound-service.xml.c \
+ sound-service-marshal.c \
+ sound-service-marshal.h \
$(music_bridge_VALASOURCES:.vala=.c)
indicator_sound_service_CFLAGS = $(PULSEAUDIO_CFLAGS) $(SOUNDSERVICE_CFLAGS) $(GCONF_CFLAGS) -DLIBEXECDIR=\"$(libexecdir)\" -Wall
@@ -147,3 +154,7 @@ BUILT_SOURCES = \
CLEANFILES = \
$(BUILT_SOURCES)
+
+DISTCLEANFILES =
+
+include $(top_srcdir)/Makefile.am.marshal