aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2013-11-15 22:11:57 -0600
committerTed Gould <ted@gould.cx>2013-11-15 22:11:57 -0600
commit30e3f1f9d404c77ee32d2e004c2c9327192f5872 (patch)
tree485aab0f1d667ec87e21b59d2a079f235e25e60e /tests/CMakeLists.txt
parent436a5a3a347b7c0946e5e53f721f0f7d2fd53062 (diff)
downloadayatana-indicator-sound-30e3f1f9d404c77ee32d2e004c2c9327192f5872.tar.gz
ayatana-indicator-sound-30e3f1f9d404c77ee32d2e004c2c9327192f5872.tar.bz2
ayatana-indicator-sound-30e3f1f9d404c77ee32d2e004c2c9327192f5872.zip
Okay, no we're testing something!
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 1e5448d..8e79fd0 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -15,7 +15,8 @@ target_link_libraries(gtest ${GTEST_LIBS})
# Name Watch Test
###########################
-add_executable (name-watch-test name-watch-test.cc)
-target_link_libraries (name-watch-test gtest ${GIO2_LIBRARIES})
+include_directories(${CMAKE_SOURCE_DIR}/src)
+add_executable (name-watch-test name-watch-test.cc ${CMAKE_SOURCE_DIR}/src/bus-watch-namespace.c)
+target_link_libraries (name-watch-test gtest ${SOUNDSERVICE_LIBRARIES})
add_test(name-watch-test name-watch-test)