aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-02-11 21:29:30 -0600
committerTed Gould <ted@gould.cx>2014-02-11 21:29:30 -0600
commit3dceea54230f478ca188b4987ef352e13ea09f69 (patch)
treee22e6fe6bd007a6f98db9c11a35eafcb372952e0 /tests/CMakeLists.txt
parent66edc177867c09e696552a73862c29485194e704 (diff)
downloadayatana-indicator-sound-3dceea54230f478ca188b4987ef352e13ea09f69.tar.gz
ayatana-indicator-sound-3dceea54230f478ca188b4987ef352e13ea09f69.tar.bz2
ayatana-indicator-sound-3dceea54230f478ca188b4987ef352e13ea09f69.zip
Allocating an object and working around libaccountsservice0
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index e6a5f34..b25b20a 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -26,6 +26,12 @@ add_test(name-watch-test name-watch-test)
include_directories(${CMAKE_SOURCE_DIR}/src)
add_executable (accounts-service-user-test accounts-service-user.cc)
-target_link_libraries (accounts-service-user-test gtest ${SOUNDSERVICE_LIBRARIES} ${TEST_LIBRARIES})
+target_link_libraries (
+ accounts-service-user-test
+ indicator-sound-service-lib
+ gtest
+ ${SOUNDSERVICE_LIBRARIES}
+ ${TEST_LIBRARIES}
+)
add_test(accounts-service-user-test accounts-service-user-test)