aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-12-16 13:16:20 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-02-17 16:49:35 +0100
commit61d803b7701f030f5f8e1bf1f0b183056ee4dfc4 (patch)
tree6960ca929e5db71b44256ae3901e5078b6125625 /tests/CMakeLists.txt
parent111165eede28d96c9687c93999d528d39a5a2954 (diff)
downloadayatana-indicator-sound-61d803b7701f030f5f8e1bf1f0b183056ee4dfc4.tar.gz
ayatana-indicator-sound-61d803b7701f030f5f8e1bf1f0b183056ee4dfc4.tar.bz2
ayatana-indicator-sound-61d803b7701f030f5f8e1bf1f0b183056ee4dfc4.zip
Make Lomiri features configurable at build time
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 3e03a20..9a72e0e 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -34,8 +34,8 @@ add_custom_target (
set (XDG_DATA_DIRS "${CMAKE_CURRENT_BINARY_DIR}/gsettings-schemas")
set (SCHEMA_DIR "${XDG_DATA_DIRS}/glib-2.0/schemas")
-if(LOMIRI_SCHEMAS_FOUND)
- add_definitions ( -DHAS_LOMIRI_SCHEMAS )
+if(ENABLE_LOMIRI_FEATURES)
+ add_definitions ( -DLOMIRI_FEATURES_ENABLED )
endif()
add_definitions(-DSCHEMA_DIR="${SCHEMA_DIR}")
@@ -324,7 +324,7 @@ add_test(indicator-test
indicator-test
)
-if (LOMIRI_API_FOUND AND LOMIRI_SCHEMAS_FOUND)
+if (ENABLE_LOMIRI_FEATURES)
add_subdirectory(integration)
endif()
add_subdirectory(dbus-types)