aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2015-02-09 15:25:54 -0600
committerTed Gould <ted@gould.cx>2015-02-09 15:25:54 -0600
commit6808a4cb98497c61e3d6a202f94f09469f7a20a2 (patch)
tree02e618eea49930aa6017d472755efa5d4d6b4290 /tests/CMakeLists.txt
parentea846294e73c242b6574085533a9899a585eecf9 (diff)
downloadayatana-indicator-sound-6808a4cb98497c61e3d6a202f94f09469f7a20a2.tar.gz
ayatana-indicator-sound-6808a4cb98497c61e3d6a202f94f09469f7a20a2.tar.bz2
ayatana-indicator-sound-6808a4cb98497c61e3d6a202f94f09469f7a20a2.zip
Creating a skeleton to start testing
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 38a76ae..f6f8644 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -65,6 +65,10 @@ vala_add(vala-mocks
media-player-mock.vala
)
+vala_add(vala-mocks
+ volume-control-mock.vala
+)
+
vala_finish(vala-mocks
SOURCES
vala_mocks_VALA_SOURCES
@@ -184,6 +188,23 @@ target_link_libraries (
add_test(sound-menu-test sound-menu-test)
###########################
+# Notification Test
+###########################
+
+include_directories(${CMAKE_SOURCE_DIR}/src)
+add_executable (notifications-test notifications-test.cc)
+target_link_libraries (
+ notifications-test
+ indicator-sound-service-lib
+ vala-mocks-lib
+ gtest
+ ${SOUNDSERVICE_LIBRARIES}
+ ${TEST_LIBRARIES}
+)
+
+add_test(notifications-test notifications-test)
+
+###########################
# Accounts Service User
###########################