aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-02-11 20:27:19 -0600
committerTed Gould <ted@gould.cx>2014-02-11 20:27:19 -0600
commit7da8553896b1967d44292e211e9573e2d2d18e74 (patch)
treecf28dc89dd7ee7560a227f1daef544d8cccd22d2 /tests/CMakeLists.txt
parenteca0a6a44fce6efe86905940c3ce2562e18d3502 (diff)
downloadayatana-indicator-sound-7da8553896b1967d44292e211e9573e2d2d18e74.tar.gz
ayatana-indicator-sound-7da8553896b1967d44292e211e9573e2d2d18e74.tar.bz2
ayatana-indicator-sound-7da8553896b1967d44292e211e9573e2d2d18e74.zip
Adding in an accounts service base test
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 8e79fd0..e6a5f34 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -20,3 +20,12 @@ add_executable (name-watch-test name-watch-test.cc ${CMAKE_SOURCE_DIR}/src/bus-w
target_link_libraries (name-watch-test gtest ${SOUNDSERVICE_LIBRARIES})
add_test(name-watch-test name-watch-test)
+###########################
+# Accounts Service User
+###########################
+
+include_directories(${CMAKE_SOURCE_DIR}/src)
+add_executable (accounts-service-user-test accounts-service-user.cc)
+target_link_libraries (accounts-service-user-test gtest ${SOUNDSERVICE_LIBRARIES} ${TEST_LIBRARIES})
+add_test(accounts-service-user-test accounts-service-user-test)
+