aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-03-03 15:33:21 -0600
committerTed Gould <ted@gould.cx>2014-03-03 15:33:21 -0600
commita251c36b195cf1e24a6934c4ea667b753a1ee538 (patch)
tree156c97d2de87cac9b6534f4789c638ede87ed824 /tests/CMakeLists.txt
parent1eb67f3e7b3d86e8ea17a65210992e275755ba83 (diff)
downloadayatana-indicator-sound-a251c36b195cf1e24a6934c4ea667b753a1ee538.tar.gz
ayatana-indicator-sound-a251c36b195cf1e24a6934c4ea667b753a1ee538.tar.bz2
ayatana-indicator-sound-a251c36b195cf1e24a6934c4ea667b753a1ee538.zip
Setting up a test for the media player user
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt23
1 files changed, 22 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 0247998..d4aa66e 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -116,7 +116,7 @@ add_test(accounts-service-user-test-player
)
###########################
-# Accounts Service User
+# Sound Menu
###########################
include_directories(${CMAKE_SOURCE_DIR}/src)
@@ -131,3 +131,24 @@ target_link_libraries (
)
add_test(sound-menu-test sound-menu-test)
+
+###########################
+# Accounts Service User
+###########################
+
+include_directories(${CMAKE_SOURCE_DIR}/src)
+add_executable (media-player-user-test media-player-user.cc)
+target_link_libraries (
+ media-player-user-test
+ indicator-sound-service-lib
+ vala-mocks-lib
+ gtest
+ ${SOUNDSERVICE_LIBRARIES}
+ ${TEST_LIBRARIES}
+)
+
+# Split tests to work around libaccountservice sucking
+add_test(media-player-user-test-basic
+ media-player-user-test --gtest_filter=MediaPlayerUserTest.BasicObject
+)
+