aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2015-01-28 16:43:18 -0600
committerTed Gould <ted@gould.cx>2015-01-28 16:43:18 -0600
commitaf63886e47b8262189d54712dbb34383ecf83669 (patch)
tree4be682091795d3477cc4792d8a4d6b618f0b827c /tests/CMakeLists.txt
parent8210778317cd8f8be803f4afa0200bd9cad0f68e (diff)
parent8fc91cb9823afc3b4dcaa03422c3dc4611ab034f (diff)
downloadayatana-indicator-sound-af63886e47b8262189d54712dbb34383ecf83669.tar.gz
ayatana-indicator-sound-af63886e47b8262189d54712dbb34383ecf83669.tar.bz2
ayatana-indicator-sound-af63886e47b8262189d54712dbb34383ecf83669.zip
Bring in the PA Mock
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index f588d12..c1b4afc 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -83,6 +83,16 @@ target_link_libraries(
include_directories(${CMAKE_CURRENT_BINARY_DIR})
###########################
+# Pulse Mock
+###########################
+
+add_library(
+ pulse-mock
+ SHARED
+ pa-mock.cpp
+)
+
+###########################
# Name Watch Test
###########################
@@ -116,6 +126,22 @@ add_test(accounts-service-user-test-player
)
###########################
+# Volume Control
+###########################
+
+include_directories(${CMAKE_SOURCE_DIR}/src)
+add_executable (volume-control-test volume-control-test.cc)
+target_link_libraries (
+ volume-control-test
+ indicator-sound-service-lib
+ pulse-mock
+ gtest
+ ${TEST_LIBRARIES}
+)
+
+add_test(volume-control-test volume-control-test)
+
+###########################
# Sound Menu
###########################