aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-12 16:00:45 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-12 16:00:45 +0100
commitafd70079f631e8a19c8f1c3049bed28e9afe7891 (patch)
tree0d9256966cf032c8de24cd0c46a20460d354e1fc /tests/CMakeLists.txt
parent5eab5bda27cbf8837addbc480ebab5e75a6e1372 (diff)
downloadayatana-indicator-sound-afd70079f631e8a19c8f1c3049bed28e9afe7891.tar.gz
ayatana-indicator-sound-afd70079f631e8a19c8f1c3049bed28e9afe7891.tar.bz2
ayatana-indicator-sound-afd70079f631e8a19c8f1c3049bed28e9afe7891.zip
tests/CMakeLists.txt: Handle custom command (gschemas.compiled) indirectly via custom target (gschemas-compiled).
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 131a648..68c0fcc 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -35,6 +35,10 @@ add_custom_command (OUTPUT gschemas.compiled
add_custom_command (OUTPUT test-home
COMMAND mkdir -p $(TEST_HOME))
+add_custom_target (
+ gschemas-compiled ALL DEPENDS gschemas.compiled
+)
+
###########################
# Vala Mocks
###########################
@@ -173,7 +177,8 @@ add_test(accounts-service-user-test-player
###########################
include_directories(${CMAKE_SOURCE_DIR}/src)
-add_executable (volume-control-test volume-control-test.cc gschemas.compiled)
+add_executable (volume-control-test volume-control-test.cc)
+add_dependencies (volume-control-test gschemas-compiled)
target_link_libraries (
volume-control-test
indicator-sound-service-lib
@@ -277,7 +282,8 @@ add_definitions(
-DINDICATOR_SOUND_SERVICE_BINARY="${CMAKE_BINARY_DIR}/src/ayatana-indicator-sound-service"
-DPA_MOCK_LIB="${CMAKE_CURRENT_BINARY_DIR}/libpulse-mock.so"
)
-add_executable (indicator-test indicator-test.cc gschemas.compiled)
+add_executable (indicator-test indicator-test.cc)
+add_dependencies (indicator-test gschemas-compiled)
target_link_libraries (
indicator-test
${SOUNDSERVICE_LIBRARIES}