aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-10-28 18:01:35 -0500
committerTed Gould <ted@gould.cx>2014-10-28 18:01:35 -0500
commitb0ac3df28f96e54d0adca7ba32a4993faffc44d2 (patch)
tree11f9b15f524f83ff2bdb633ada3b7c15d737f604 /tests/CMakeLists.txt
parentdec2d5350f47e52539941b45d394516066a19678 (diff)
downloadayatana-indicator-sound-b0ac3df28f96e54d0adca7ba32a4993faffc44d2.tar.gz
ayatana-indicator-sound-b0ac3df28f96e54d0adca7ba32a4993faffc44d2.tar.bz2
ayatana-indicator-sound-b0ac3df28f96e54d0adca7ba32a4993faffc44d2.zip
Setup to getting something to compile and pass. Next steps needed.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index ae68c45..1eec3fd 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -181,3 +181,18 @@ add_test(greeter-list-test-iterator
greeter-list-test --gtest_filter=GreeterListTest.BasicIterator
)
+###########################
+# Indicator Test
+###########################
+
+add_executable (indicator-test indicator-test.cc)
+target_link_libraries (
+ indicator-test
+ gtest
+ ${SOUNDSERVICE_LIBRARIES}
+ ${TEST_LIBRARIES}
+)
+
+# Split tests to work around libaccountservice sucking
+add_test(indicator-test indicator-test)
+