aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-02-12 15:13:11 -0600
committerTed Gould <ted@gould.cx>2014-02-12 15:13:11 -0600
commitc2a9d0e2995ea7d32e0f3d82886ac34517694698 (patch)
treef49183544ca1b001f05ba6c4346402f1aa36db25 /tests/CMakeLists.txt
parent18121baa3297e11eb064b4f0ad0c02ff5316ea95 (diff)
downloadayatana-indicator-sound-c2a9d0e2995ea7d32e0f3d82886ac34517694698.tar.gz
ayatana-indicator-sound-c2a9d0e2995ea7d32e0f3d82886ac34517694698.tar.bz2
ayatana-indicator-sound-c2a9d0e2995ea7d32e0f3d82886ac34517694698.zip
Get the player test put together
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 09073b9..a703d24 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -104,5 +104,12 @@ target_link_libraries (
${SOUNDSERVICE_LIBRARIES}
${TEST_LIBRARIES}
)
-add_test(accounts-service-user-test accounts-service-user-test)
+# Split tests to work around libaccountservice sucking
+add_test(accounts-service-user-test-basic
+ accounts-service-user-test --gtest_filter=AccountsServiceUserTest.BasicObject
+)
+
+add_test(accounts-service-user-test-player
+ accounts-service-user-test --gtest_filter=AccountsServiceUserTest.SetMediaPlayer
+)