aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2015-01-26 16:53:28 -0600
committerTed Gould <ted@gould.cx>2015-01-26 16:53:28 -0600
commitd788cd8f6910a8ff17454cc54175815a122f0c63 (patch)
tree2a2f6d199e04649927883a27a5d8beed7fd9845a /tests/CMakeLists.txt
parent7200c1ba22c4c8155af58784b1dacdc0a06cf93a (diff)
downloadayatana-indicator-sound-d788cd8f6910a8ff17454cc54175815a122f0c63.tar.gz
ayatana-indicator-sound-d788cd8f6910a8ff17454cc54175815a122f0c63.tar.bz2
ayatana-indicator-sound-d788cd8f6910a8ff17454cc54175815a122f0c63.zip
IT COMPILES!
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index ae68c45..5c37ea3 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -83,6 +83,21 @@ target_link_libraries(
include_directories(${CMAKE_CURRENT_BINARY_DIR})
###########################
+# Pulse Mock
+###########################
+
+add_library(
+ pulse-mock
+ SHARED
+ pa-mock.c
+)
+
+target_link_libraries(
+ pulse-mock
+ ${SOUNDSERVICE_LIBRARIES}
+)
+
+###########################
# Name Watch Test
###########################