aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorXavi Garcia Mena <xavi.garcia.mena@canonical.com>2015-09-23 16:10:54 +0200
committerXavi Garcia Mena <xavi.garcia.mena@canonical.com>2015-09-23 16:10:54 +0200
commiteb22c54e4587e5941378b066ec8220a56d26db4b (patch)
treeae85ae46280dc6bd1c27c85bec9413c59c264808 /tests/CMakeLists.txt
parentb9ef4f6abdefb7b1d31d34f35b742016f1b5b87f (diff)
downloadayatana-indicator-sound-eb22c54e4587e5941378b066ec8220a56d26db4b.tar.gz
ayatana-indicator-sound-eb22c54e4587e5941378b066ec8220a56d26db4b.tar.bz2
ayatana-indicator-sound-eb22c54e4587e5941378b066ec8220a56d26db4b.zip
Added test MPRIS player integration test
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index d818a2d..adc08de 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -22,7 +22,8 @@ set_source_files_properties (gschemas.compiled GENERATED)
# GSettings:
# compile the indicator-sound schema into a gschemas.compiled file in this directory,
# and help the tests to find that file by setting -DSCHEMA_DIR
-set (SCHEMA_DIR "${CMAKE_CURRENT_BINARY_DIR}/gsettings-schemas")
+set (XDG_DATA_DIRS "${CMAKE_CURRENT_BINARY_DIR}/gsettings-schemas")
+set (SCHEMA_DIR "${XDG_DATA_DIRS}/glib-2.0/schemas")
add_definitions(-DSCHEMA_DIR="${SCHEMA_DIR}")
execute_process (COMMAND ${PKG_CONFIG_EXECUTABLE} gio-2.0 --variable glib_compile_schemas
OUTPUT_VARIABLE COMPILE_SCHEMA_EXECUTABLE
@@ -31,6 +32,7 @@ add_custom_command (OUTPUT gschemas.compiled
DEPENDS ${CMAKE_SOURCE_DIR}/data/com.canonical.indicator.sound.gschema.xml
COMMAND mkdir -p ${SCHEMA_DIR}
COMMAND cp -f ${CMAKE_SOURCE_DIR}/data/*gschema.xml ${SCHEMA_DIR}
+ COMMAND cp -f /usr/share/glib-2.0/schemas/com.ubuntu.sound.gschema.xml ${SCHEMA_DIR}
COMMAND ${COMPILE_SCHEMA_EXECUTABLE} ${SCHEMA_DIR})
###########################
@@ -281,4 +283,4 @@ add_test(indcator-test
add_subdirectory(integration)
add_subdirectory(dbus-types)
-add_subdirectory(accounts-mock) \ No newline at end of file
+add_subdirectory(service-mocks) \ No newline at end of file