aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2010-03-09 09:24:36 +1100
committerRobert Collins <robertc@robertcollins.net>2010-03-09 09:24:36 +1100
commit2e85d8a7db825a7aef087710abe8159a716df6c7 (patch)
treeaa7fe45eea82e19083b2525a05085880ee0e571d /tests/Makefile.am
parent56f9654524bbf61a625905fe9e9dcaa63eaf71b5 (diff)
downloadayatana-indicator-sound-2e85d8a7db825a7aef087710abe8159a716df6c7.tar.gz
ayatana-indicator-sound-2e85d8a7db825a7aef087710abe8159a716df6c7.tar.bz2
ayatana-indicator-sound-2e85d8a7db825a7aef087710abe8159a716df6c7.zip
snapshot closer-to-building.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am34
1 files changed, 29 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index bbae7fe..7573ea5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,11 +4,13 @@ check_PROGRAMS = \
test-indicator-sound-dbus-client \
test-indicator-sound-dbus-server
-TESTS = test-indicator-sound
+TESTS = \
+ test-indicator-sound \
+ test-pulse-manager
DISTCLEANFILES = $(TESTS)
noinst_LTLIBRARIES = libmockpulse.la
-libmockpulse_la_SOURCES = mockpulse.c
+libmockpulse_la_SOURCES = mockpulse.c mockpulse.h
libmockpulse_la_CFLAGS = $(PULSEAUDIO_CFLAGS)
@@ -45,10 +47,9 @@ test_indicator_sound_dbus_client_CFLAGS = \
$(SOUNDSERVICE_CFLAGS) \
-Wall -Werror \
-I$(srcdir) \
- -I$(SOUNDSERVICE_CFLAGS)
+ -I$(SOUNDSERVICE_CFLAGS)
test_indicator_sound_dbus_client_LDADD = \
- libmockpulse.la \
$(PULSEAUDIO_LIBS) \
$(SOUNDSERVICE_LIBS)
@@ -69,9 +70,32 @@ test_indicator_sound_dbus_server_CFLAGS = \
-I$(srcdir)
test_indicator_sound_dbus_server_LDADD = \
- $(SOUNDSERVICE_LIBS) \
+ $(SOUNDSERVICE_LIBS) \
$(PULSEAUDIO_LIBS)
+#########################################
+## test-pulse-manager
+#########################################
+
+check_PROGRAMS += test-pulse-manager
+
+test_pulse_manager_SOURCES = \
+ test-pulse-manager.c
+
+test_pulse_manager_CFLAGS = \
+ $(PULSEAUDIO_CFLAGS) \
+ $(SOUNDSERVICE_CFLAGS) \
+ $(GCONF_CFLAGS) \
+ -Wall -Werror \
+ -I$(srcdir) \
+ -I$(SOUNDSERVICE_CFLAGS)
+
+test_pulse_manager_LDADD = \
+ libmockpulse.la \
+ $(PULSEAUDIO_LIBS) \
+ $(SOUNDSERVICE_LIBS) \
+ $(GCONF_LIBS)
+
#########################################
## Actual tests