aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2010-03-02 00:18:04 +0000
committerConor Curran <conor.curran@canonical.com>2010-03-02 00:18:04 +0000
commita6152fcf5ec57d7252617a7ede36aa53de7f2930 (patch)
treeabce27406eaa2fe29e1705b0b38b81cd947871af /tests/Makefile.am
parent6468402475d7bfced0ee905bdd56977cc2f4b7da (diff)
parent7a92d249547ff1783725850edb39a952e52ee8c9 (diff)
downloadayatana-indicator-sound-a6152fcf5ec57d7252617a7ede36aa53de7f2930.tar.gz
ayatana-indicator-sound-a6152fcf5ec57d7252617a7ede36aa53de7f2930.tar.bz2
ayatana-indicator-sound-a6152fcf5ec57d7252617a7ede36aa53de7f2930.zip
slow progress on the testing front
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7d061fb..285a26c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
check_PROGRAMS = \
- test-indicator-sound
+ test-indicator-sound \
test-indicator-sound-dbus-client \
test-indicator-sound-dbus-server
@@ -21,7 +21,8 @@ test_indicator_sound_CFLAGS = \
test_indicator_sound_LDADD = \
$(APPLET_LIBS) \
- $(INDICATORDIR)/libsoundmenu.la
+ $(top_builddir)/src/libsoundmenu_la-indicator-sound.o
+
#########################################
## test-indicator-sound-dbus-client
@@ -38,8 +39,7 @@ test_indicator_sound_dbus_client_CFLAGS = \
-I$(SOUNDSERVICE_CFLAGS)
test_indicator_sound_dbus_client_LDADD = \
- $(SOUNDSERVICE_LIBS) \
- $(INDICATORDIR)/libsoundmenu.la
+ $(SOUNDSERVICE_LIBS)
#########################################
## test-indicator-sound-dbus-server
@@ -51,11 +51,15 @@ test_indicator_sound_dbus_server_SOURCES = \
test_indicator_sound_dbus_server_CFLAGS = \
$(APPLET_CFLAGS) \
-Wall -Werror \
- -I$(srcdir)
+ -I$(srcdir) \
+ -I$(SOUNDSERVICE_CFLAGS)
-test_libappindicator_dbus_server_LDADD = \
+test_indicator_sound_dbus_server_LDADD = \
$(SOUNDSERVICE_LIBS) \
- $(INDICATORDIR)/libsoundmenu.la
+ $(top_builddir)/src/libsoundmenu.la
+
+
+
#########################################