aboutsummaryrefslogtreecommitdiff
path: root/tests/dbus-types/CMakeLists.txt
diff options
context:
space:
mode:
authorXavi Garcia Mena <xavi.garcia.mena@canonical.com>2015-12-02 14:44:58 +0100
committerXavi Garcia Mena <xavi.garcia.mena@canonical.com>2015-12-02 14:44:58 +0100
commitd9a00604c1d8e3103444053da39a4af17230903b (patch)
treea58e2a32d3e7c9fd603be00262914612e2efb902 /tests/dbus-types/CMakeLists.txt
parent7c69f81a079a08d58241cc50365dde7d37ad3345 (diff)
downloadayatana-indicator-sound-d9a00604c1d8e3103444053da39a4af17230903b.tar.gz
ayatana-indicator-sound-d9a00604c1d8e3103444053da39a4af17230903b.tar.bz2
ayatana-indicator-sound-d9a00604c1d8e3103444053da39a4af17230903b.zip
Added integration tests
Diffstat (limited to 'tests/dbus-types/CMakeLists.txt')
-rw-r--r--tests/dbus-types/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/dbus-types/CMakeLists.txt b/tests/dbus-types/CMakeLists.txt
index cb7f512..a50a5bb 100644
--- a/tests/dbus-types/CMakeLists.txt
+++ b/tests/dbus-types/CMakeLists.txt
@@ -26,7 +26,8 @@ set_source_files_properties(${dbusinterface_properties_xml} PROPERTIES
set(dbusinterface_actions_xml "org.gtk.Actions.xml")
set_source_files_properties(${dbusinterface_actions_xml} PROPERTIES
- CLASSNAME MenusInterface)
+ CLASSNAME MenusInterface
+ INCLUDE "dbus-action-result.h")
set(dbusinterface_notifications_xml "org.freedesktop.Notifications.xml")
set_source_files_properties(${dbusinterface_notifications_xml} PROPERTIES
@@ -44,6 +45,7 @@ add_library(
STATIC
${interface_files}
pulseaudio-volume.cpp
+ dbus-action-result.cpp
)
qt5_use_modules(