aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
authorXavi Garcia Mena <xavi.garcia.mena@canonical.com>2015-09-18 15:15:59 +0200
committerXavi Garcia Mena <xavi.garcia.mena@canonical.com>2015-09-18 15:15:59 +0200
commit09fc613f1ce55910698aca6b8b5d909ac3ae77a0 (patch)
tree3da08a9132673043b143e20b102b7489e704c5e8 /tests/integration/CMakeLists.txt
parent348a81decd37889ad46086383f5910f12a00c3c9 (diff)
downloadayatana-indicator-sound-09fc613f1ce55910698aca6b8b5d909ac3ae77a0.tar.gz
ayatana-indicator-sound-09fc613f1ce55910698aca6b8b5d909ac3ae77a0.tar.bz2
ayatana-indicator-sound-09fc613f1ce55910698aca6b8b5d909ac3ae77a0.zip
Added AccountsService Mock to the integration tests
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
index 2e4004a..ace155a 100644
--- a/tests/integration/CMakeLists.txt
+++ b/tests/integration/CMakeLists.txt
@@ -29,6 +29,7 @@ include_directories("${CMAKE_BINARY_DIR}/tests/dbus-types")
add_definitions(-DSOUND_SERVICE_BIN="${CMAKE_BINARY_DIR}/src/indicator-sound-service"
-DSTREAM_RESTORE_TABLE="${CMAKE_SOURCE_DIR}/tests/integration/touch-stream-restore.table"
-DVOLUME_SET_BIN="${CMAKE_BINARY_DIR}/tests/integration/set-volume"
+ -DACCOUNTS_SERVICE_BIN="${CMAKE_BINARY_DIR}/tests/accounts-mock/accounts-service-sound"
-DTEST_SOUND="${CMAKE_SOURCE_DIR}/tests/integration/test-sound.wav"
-DQT_NO_KEYWORDS=1
)