aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-01-13 00:52:50 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-01-13 00:52:50 +0100
commit73262741e8480f6161659275c9d9239e6351d011 (patch)
tree47d6987cd3a6ef021f0f1191882d0a906b9428bd /tests/integration/CMakeLists.txt
parent66412674cb282a7f0e0c8c29cfeb1d2f8c4c3de1 (diff)
downloadayatana-indicator-sound-73262741e8480f6161659275c9d9239e6351d011.tar.gz
ayatana-indicator-sound-73262741e8480f6161659275c9d9239e6351d011.tar.bz2
ayatana-indicator-sound-73262741e8480f6161659275c9d9239e6351d011.zip
tests/integration/: Provider a FAKE_HOME for pulseaudio to have a secure location for its user config files.
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
index bee5451..a19c789 100644
--- a/tests/integration/CMakeLists.txt
+++ b/tests/integration/CMakeLists.txt
@@ -32,6 +32,7 @@ add_definitions(-DSOUND_SERVICE_BIN="${CMAKE_BINARY_DIR}/src/ayatana-indicator-s
-DTEST_SOUND="${CMAKE_SOURCE_DIR}/tests/integration/test-sound.wav"
-DQT_NO_KEYWORDS=1
-DXDG_DATA_DIRS="${XDG_DATA_DIRS}"
+ -DFAKE_HOME="${FAKE_HOME}"
)
set(GLIB_REQUIRED_VERSION 2.26)