aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
authorRatchanan Srirattanamet <ratchanan@ubports.com>2020-04-27 17:58:04 +0700
committerRobert Tari <robert@tari.in>2021-08-12 02:25:11 +0200
commitef802adfb4afe44ae2ef529275aadc2629d7170f (patch)
tree5f24bc66baf1cd8c648c7f71fe1575463e2347c0 /tests/integration/CMakeLists.txt
parentf193bca3b029fa2e379f61e28bb1e4b38ec43fac (diff)
downloadayatana-indicator-sound-ef802adfb4afe44ae2ef529275aadc2629d7170f.tar.gz
ayatana-indicator-sound-ef802adfb4afe44ae2ef529275aadc2629d7170f.tar.bz2
ayatana-indicator-sound-ef802adfb4afe44ae2ef529275aadc2629d7170f.zip
integration-test: provide a temporary HOME directory to the test
A couple of things in the integration-test rely on having a HOME directory. Provide a temporary HOME for the test and its child, which both prevents polluting the building user's HOME and allow the test to run where HOME=/nonexistent (i.e. autobuilder). Also remove the exception not to run the integration test inside the (Canonical's) Jenkins, as it's not relevant anymore.
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
index 74b9c23..e803a87 100644
--- a/tests/integration/CMakeLists.txt
+++ b/tests/integration/CMakeLists.txt
@@ -87,19 +87,6 @@ target_link_libraries(
gmenuharness-shared
)
-####
-## When building under jenkins, pulseuadio fails to start as there is no
-## /run/user tree, HOME directory is missing, and similar issues. So here
-## we check that we are the jenkins user, and avoid the integration tests,
-## until such time in future when we can run these tests in some different
-## manner to avoid needing to run pulseaudio in this way.
-####
-execute_process(
- COMMAND whoami
- OUTPUT_VARIABLE TESTS_USER
- OUTPUT_STRIP_TRAILING_WHITESPACE
-)
-
add_test(
integration-tests
integration-tests