aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt22
1 files changed, 21 insertions, 1 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index e71051e..ec27376 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -17,7 +17,7 @@ install(
)
###########################
-# Dbus Service
+# Upstart Job
###########################
set(
@@ -37,6 +37,26 @@ install(
)
###########################
+# XDG Autostart
+###########################
+
+set(
+ INDICATOR_SOUND_XDG_AUTOSTART
+ "${CMAKE_CURRENT_BINARY_DIR}/indicator-sound.desktop"
+)
+
+configure_file(
+ "indicator-sound.desktop.in"
+ ${INDICATOR_SOUND_CONF}
+ @ONLY
+)
+
+install(
+ FILES "${INDICATOR_SOUND_XDG_AUTOSTART}"
+ DESTINATION "/etc/xdg/autostart"
+)
+
+###########################
# GSettings
###########################