aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/control17
-rw-r--r--debian/indicator-sound-gtk2.install1
-rw-r--r--debian/indicator-sound.install1
-rwxr-xr-xdebian/rules25
5 files changed, 33 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index 9694512..1c6eb6f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-indicator-sound (0.7.1-0ubuntu1) oneiric; urgency=low
+indicator-sound (0.7.1-0ubuntu1) UNRELEASED; urgency=low
* New upstream release.
- "Sound Preferences..." should be "Sound Settings" (LP: #785571)
diff --git a/debian/control b/debian/control
index 7d45ccb..899dcbb 100644
--- a/debian/control
+++ b/debian/control
@@ -8,12 +8,16 @@ Build-Depends: debhelper (>= 7),
autotools-dev,
libglib2.0-dev (>= 2.22.3),
libgtk2.0-dev (>= 2.12.0),
+ libgtk-3-dev,
libdbusmenu-glib-dev (>= 0.3.101),
- libdbusmenu-gtk-dev (>= 0.3.101) ,
+ libdbusmenu-gtk-dev (>= 0.3.101),
+ libdbusmenu-gtk3-dev (>= 0.3.101),
libindicator-dev (>= 0.3.19),
+ libindicator3-dev (>= 0.3.19),
libpulse-dev (>= 0.9.18),
libpulse-mainloop-glib0 (>= 0.9.18),
libido-0.1-dev (>= 0.1.11),
+ libido3-0.1-dev (>= 0.2.90),
libgconf2-dev,
libgee-dev,
libxml2-dev,
@@ -31,3 +35,14 @@ Depends: ${shlibs:Depends},
Description: System sound indicator.
System sound indicator which provides easy control of the PulseAudio sound
daemon.
+
+Package: indicator-sound-gtk2
+Architecture: any
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ indicator-sound (= ${binary:Version}),
+ pulseaudio
+Replaces: indicator-sound (<< 0.7.1)
+Description: System sound indicator.
+ System sound indicator which provides easy control of the PulseAudio sound
+ daemon.
diff --git a/debian/indicator-sound-gtk2.install b/debian/indicator-sound-gtk2.install
new file mode 100644
index 0000000..8d1fc9f
--- /dev/null
+++ b/debian/indicator-sound-gtk2.install
@@ -0,0 +1 @@
+debian/tmp/gtk2/usr/lib/indicators /usr/lib/
diff --git a/debian/indicator-sound.install b/debian/indicator-sound.install
new file mode 100644
index 0000000..19a45de
--- /dev/null
+++ b/debian/indicator-sound.install
@@ -0,0 +1 @@
+debian/tmp/gtk3/usr /
diff --git a/debian/rules b/debian/rules
index d778ba1..7950ed1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,20 +1,23 @@
#!/usr/bin/make -f
+DEB_BUILDDIR = build
+DEB_MAKE_FLAVORS = gtk2 gtk3
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
-include /usr/share/cdbs/1/rules/autoreconf.mk
-# List any files which are not installed
-include /usr/share/cdbs/1/rules/utils.mk
-common-binary-post-install-arch:: list-missing
+DEB_MAKE_DESTDIRSKEL = $(CURDIR)/debian/tmp/@FLAVOR@
+DEB_DESTDIR = $(CURDIR)/debian/tmp/$(cdbs_make_curflavor)/
-LDFLAGS += -Wl,-z,defs -Wl,-O1 -Wl,--as-needed
+DEB_CONFIGURE_FLAGS_gtk2 = --with-gtk=2
+DEB_CONFIGURE_FLAGS_gtk3 = --with-gtk=3
+DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
-DEB_DH_MAKESHLIBS_ARGS = -Xusr/lib/indicators
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-binary-install/indicator-sound::
- # remove .a/.la clutter
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.a
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.la
+debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)
+debian/stamp-autotools/gtk3: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk3)
+common-install-arch::
+ find debian/tmp -name \*.la -delete
+ find debian/tmp -name \*.a -delete