aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/patches/disable_Werror.patch30
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules1
4 files changed, 11 insertions, 31 deletions
diff --git a/debian/changelog b/debian/changelog
index 604c0eb..0cb0725 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+indicator-sound (0.8.0.0-0ubuntu3) precise; urgency=low
+
+ * rebuild for libindicator7
+ * debian/rules
+ - build with no-error=deprecated-declarations
+ * -debian/patches/disable_Werror.patch
+ - disabled in debian/rules instead
+
+ -- Ken VanDine <ken.vandine@canonical.com> Wed, 25 Jan 2012 10:00:00 -0500
+
indicator-sound (0.8.0.0-0ubuntu2) precise; urgency=low
* Add lazy_init.patch: Avoid spawning notification daemon right at startup,
diff --git a/debian/patches/disable_Werror.patch b/debian/patches/disable_Werror.patch
deleted file mode 100644
index f71eb33..0000000
--- a/debian/patches/disable_Werror.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Description: Build without -Werror, to avoid build failure due to deprecated declarations.
-Author: Martin Pitt <martin.pitt@ubuntu.com>
-Bug: https://launchpad.net/bugs/912160
-
-Index: indicator-sound-0.8.0.0/src/Makefile.in
-===================================================================
---- indicator-sound-0.8.0.0.orig/src/Makefile.in 2011-12-01 19:33:43.000000000 +0100
-+++ indicator-sound-0.8.0.0/src/Makefile.in 2012-01-05 09:43:38.000000000 +0100
-@@ -357,7 +357,7 @@
- gen-sound-service.xml.c \
- dbus-shared-names.h
-
--libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror -DG_LOG_DOMAIN=\"Indicator-Sound\"
-+libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -DG_LOG_DOMAIN=\"Indicator-Sound\"
- libsoundmenu_la_LIBADD = $(APPLET_LIBS) -lm
- libsoundmenu_la_LDFLAGS = -module -avoid-version
-
-Index: indicator-sound-0.8.0.0/src/Makefile.am
-===================================================================
---- indicator-sound-0.8.0.0.orig/src/Makefile.am 2011-12-01 15:56:10.000000000 +0100
-+++ indicator-sound-0.8.0.0/src/Makefile.am 2012-01-05 09:43:52.670645999 +0100
-@@ -28,7 +28,7 @@
- gen-sound-service.xml.c \
- dbus-shared-names.h
-
--libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Werror -DG_LOG_DOMAIN=\"Indicator-Sound\"
-+libsoundmenu_la_CFLAGS = $(APPLET_CFLAGS) -Wall -DG_LOG_DOMAIN=\"Indicator-Sound\"
- libsoundmenu_la_LIBADD = $(APPLET_LIBS) -lm
- libsoundmenu_la_LDFLAGS = -module -avoid-version
-
diff --git a/debian/patches/series b/debian/patches/series
index 1dca5f0..20dfb03 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1 @@
lazy_init.patch
-disable_Werror.patch
diff --git a/debian/rules b/debian/rules
index dfd669b..f6ead0e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,7 @@ DEB_CONFIGURE_FLAGS_gtk2 = --with-gtk=2
DEB_CONFIGURE_FLAGS_gtk3 = --with-gtk=3
DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
+CFLAGS += -Wno-error=deprecated-declarations
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)