aboutsummaryrefslogtreecommitdiff
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..e78a9df
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,12 @@
+find_package(Intltool REQUIRED)
+
+intltool_update_potfile(
+ KEYWORDS "_" "_:1,2" "N_" "N_:1,2"
+ GETTEXT_PACKAGE ${GETTEXT_PACKAGE}
+ COPYRIGHT_HOLDER "Canonical Ltd."
+)
+
+intltool_install_translations(
+ ALL
+ GETTEXT_PACKAGE ${GETTEXT_PACKAGE}
+)