aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d4675df..285a26c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,7 +20,9 @@ test_indicator_sound_CFLAGS = \
-DTOP_BUILD_DIR="\"${abs_top_builddir}\""
test_indicator_sound_LDADD = \
- $(APPLET_LIBS)
+ $(APPLET_LIBS) \
+ $(top_builddir)/src/libsoundmenu_la-indicator-sound.o
+
#########################################
## test-indicator-sound-dbus-client
@@ -49,10 +51,15 @@ test_indicator_sound_dbus_server_SOURCES = \
test_indicator_sound_dbus_server_CFLAGS = \
$(APPLET_CFLAGS) \
-Wall -Werror \
- -I$(srcdir)
+ -I$(srcdir) \
+ -I$(SOUNDSERVICE_CFLAGS)
test_indicator_sound_dbus_server_LDADD = \
- $(SOUNDSERVICE_LIBS)
+ $(SOUNDSERVICE_LIBS) \
+ $(top_builddir)/src/libsoundmenu.la
+
+
+
#########################################