aboutsummaryrefslogtreecommitdiff
path: root/tests/dbus-types/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/dbus-types/CMakeLists.txt')
-rw-r--r--tests/dbus-types/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/tests/dbus-types/CMakeLists.txt b/tests/dbus-types/CMakeLists.txt
index cbe382a..1b6faed 100644
--- a/tests/dbus-types/CMakeLists.txt
+++ b/tests/dbus-types/CMakeLists.txt
@@ -15,14 +15,10 @@ set_source_files_properties(${dbusinterface_accounts_xml} PROPERTIES
CLASSNAME AccountsInterface)
if(EXISTS "/usr/share/accountsservice/interfaces/com.lomiri.AccountsService.Sound.xml")
- set(dbusinterface_accountssound_xml "com.lomiri.AccountsService.Sound.xml")
-else()
- set(dbusinterface_accountssound_xml "org.ayatana.AccountsService.Sound.xml")
+ set_source_files_properties("com.lomiri.AccountsService.Sound.xml" PROPERTIES
+ CLASSNAME AccountsSoundInterface)
endif()
-set_source_files_properties(${dbusinterface_accountssound_xml} PROPERTIES
- CLASSNAME AccountsSoundInterface)
-
set(dbusinterface_properties_xml "org.freedesktop.DBus.Properties.xml")
set_source_files_properties(${dbusinterface_properties_xml} PROPERTIES
CLASSNAME DBusPropertiesInterface
@@ -41,7 +37,11 @@ set_source_files_properties(${dbusinterface_notifications_xml} PROPERTIES
qt5_add_dbus_interface(interface_files ${dbusinterface_streamrestore_xml} stream_restore_interface)
qt5_add_dbus_interface(interface_files ${dbusinterface_properties_xml} dbus_properties_interface)
qt5_add_dbus_interface(interface_files ${dbusinterface_accounts_xml} dbus_accounts_interface)
-qt5_add_dbus_interface(interface_files ${dbusinterface_accountssound_xml} dbus_accountssound_interface)
+
+if(EXISTS "/usr/share/accountsservice/interfaces/com.lomiri.AccountsService.Sound.xml")
+ qt5_add_dbus_interface("com.lomiri.AccountsService.Sound.xml" dbus_accountssound_interface)
+endif()
+
qt5_add_dbus_interface(interface_files ${dbusinterface_actions_xml} dbus_menus_interface)
qt5_add_dbus_interface(interface_files ${dbusinterface_notifications_xml} dbus_notifications_interface)