aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
index 2bf808c..d20fa8f 100644
--- a/tests/integration/CMakeLists.txt
+++ b/tests/integration/CMakeLists.txt
@@ -32,6 +32,7 @@ add_definitions(-DSOUND_SERVICE_BIN="${CMAKE_BINARY_DIR}/src/ayatana-indicator-s
-DTEST_SOUND="${CMAKE_SOURCE_DIR}/tests/integration/test-sound.wav"
-DQT_NO_KEYWORDS=1
-DXDG_DATA_DIRS="${XDG_DATA_DIRS}"
+ -DXDG_CONFIG_HOME="${XDG_CONFIG_HOME}"
-DXDG_RUNTIME_DIR="${XDG_RUNTIME_DIR}"
-DTEST_HOME="${TEST_HOME}"
)
@@ -62,6 +63,11 @@ add_executable(
${INTEGRATION_TESTS_SRC}
)
+add_dependencies(
+ integration-tests
+ test-home
+)
+
qt5_use_modules(
integration-tests
Core
@@ -117,11 +123,21 @@ add_executable(
${SET-VOLUME-SRC}
)
+add_dependencies(
+ set-volume
+ test-home
+)
+
add_executable(
get-volume
${GET-VOLUME-SRC}
)
+add_dependencies(
+ get-volume
+ test-home
+)
+
qt5_use_modules(
set-volume
Core