aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt24
1 files changed, 12 insertions, 12 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
index 164ab8b..97c18b1 100644
--- a/tests/integration/CMakeLists.txt
+++ b/tests/integration/CMakeLists.txt
@@ -65,11 +65,11 @@ add_dependencies(
test-home
)
-qt5_use_modules(
+target_link_libraries(
integration-tests
- Core
- DBus
- Test
+ Qt5::Core
+ Qt5::DBus
+ Qt5::Test
)
target_link_options (integration-tests PRIVATE -no-pie)
@@ -120,18 +120,18 @@ add_dependencies(
test-home
)
-qt5_use_modules(
+target_link_libraries(
set-volume
- Core
- DBus
- Test
+ Qt5::Core
+ Qt5::DBus
+ Qt5::Test
)
-qt5_use_modules(
+target_link_libraries(
get-volume
- Core
- DBus
- Test
+ Qt5::Core
+ Qt5::DBus
+ Qt5::Test
)
target_link_libraries(