aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-11-09 10:08:59 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-11-09 12:34:19 +0100
commitee119c434e35a3d3addf76b718f4828b8cf0b656 (patch)
tree924ac6ee046fa15b03850b73fbc17f8f2909ed46 /setup.py
parentd4f6f03479830b5973db38015496e37938cb7780 (diff)
downloadayatana-settings-ee119c434e35a3d3addf76b718f4828b8cf0b656.tar.gz
ayatana-settings-ee119c434e35a3d3addf76b718f4828b8cf0b656.tar.bz2
ayatana-settings-ee119c434e35a3d3addf76b718f4828b8cf0b656.zip
data/applications/ayatana-settings.desktop: Don't in-file update locale strings, rather use an input and an output file.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 33f7f29..ca1d8a3 100755
--- a/setup.py
+++ b/setup.py
@@ -7,10 +7,10 @@ import os, polib, configparser
m_lstDataFiles = []
-oFile = open('data/applications/{}.desktop'.format(APPNAME), 'r+')
+iFile = open('data/applications/{}.desktop.in'.format(APPNAME), 'r')
oConfigParser = configparser.ConfigParser()
oConfigParser.optionxform = str
-oConfigParser.read_file(oFile)
+oConfigParser.read_file(iFile)
for strRoot, lstDirnames, lstFilenames in os.walk('po'):
@@ -34,7 +34,7 @@ for sSection in oConfigParser.sections():
oConfigParser[sSection] = dict(sorted(oConfigParser[sSection].items(), key=lambda lParams: lParams[0]))
-oFile.seek(0)
+oFile = open('data/applications/{}.desktop'.format(APPNAME), 'w')
oConfigParser.write(oFile, False)
oFile.truncate
@@ -62,6 +62,10 @@ for strRoot, lstDirnames, lstFilenames in os.walk('data'):
continue
+ elif strFilename == 'ayatana-settings.desktop.in':
+
+ continue
+
strPath = os.path.join(strRoot, strFilename)
m_lstDataFiles.append(("share/{data}".format(data=os.path.dirname(strPath).replace('data/', '')), [strPath]))