aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 12 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 0955d06..ca1d8a3 100755
--- a/setup.py
+++ b/setup.py
@@ -7,10 +7,10 @@ import os, polib, configparser
m_lstDataFiles = []
-oFile = open('data/usr/share/applications/{}.desktop'.format(APPNAME), 'r+')
+iFile = open('data/applications/{}.desktop.in'.format(APPNAME), 'r')
oConfigParser = configparser.ConfigParser()
oConfigParser.optionxform = str
-oConfigParser.read_file(oFile)
+oConfigParser.read_file(iFile)
for strRoot, lstDirnames, lstFilenames in os.walk('po'):
@@ -34,7 +34,7 @@ for sSection in oConfigParser.sections():
oConfigParser[sSection] = dict(sorted(oConfigParser[sSection].items(), key=lambda lParams: lParams[0]))
-oFile.seek(0)
+oFile = open('data/applications/{}.desktop'.format(APPNAME), 'w')
oConfigParser.write(oFile, False)
oFile.truncate
@@ -46,7 +46,7 @@ for strRoot, lstDirnames, lstFilenames in os.walk('po'):
if strLocale != APPNAME:
- strLocaleDir = 'data/usr/share/locale/' + strLocale + '/LC_MESSAGES/'
+ strLocaleDir = 'data/locale/' + strLocale + '/LC_MESSAGES/'
if not os.path.isdir(strLocaleDir):
@@ -62,8 +62,14 @@ for strRoot, lstDirnames, lstFilenames in os.walk('data'):
continue
+ elif strFilename == 'ayatana-settings.desktop.in':
+
+ continue
+
strPath = os.path.join(strRoot, strFilename)
- m_lstDataFiles.append((os.path.dirname(strPath).lstrip('data'), [strPath]))
+ m_lstDataFiles.append(("share/{data}".format(data=os.path.dirname(strPath).replace('data/', '')), [strPath]))
+
+m_lstDataFiles.append(('bin/', ['ayatana-settings']))
setup(
name = APPNAME,
@@ -89,5 +95,6 @@ setup(
keywords = APPKEYWORDS,
packages = [APPNAME.replace('-', '')],
data_files = m_lstDataFiles,
+ install_requires = [ 'setuptools', ],
platforms = 'UNIX'
)