aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2020-08-17 17:40:59 +0200
committerRobert Tari <robert@tari.in>2020-08-17 17:40:59 +0200
commit711050055339f6a14f0c3da4d3d28f707b97a102 (patch)
tree7c69fbc7809bc1592bab47c811c6d9e4ddf964da /debian
downloadayatana-webmail-711050055339f6a14f0c3da4d3d28f707b97a102.tar.gz
ayatana-webmail-711050055339f6a14f0c3da4d3d28f707b97a102.tar.bz2
ayatana-webmail-711050055339f6a14f0c3da4d3d28f707b97a102.zip
Initial port from Unity Mail
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/changelog5
-rwxr-xr-xdebian/compat1
-rwxr-xr-xdebian/control31
-rwxr-xr-xdebian/copyright32
-rwxr-xr-xdebian/postinst29
-rwxr-xr-xdebian/rules14
-rwxr-xr-xdebian/source/format1
-rwxr-xr-xdebian/watch2
8 files changed, 115 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100755
index 0000000..eb66034
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+ayatana-webmail (20.8.16) unstable; urgency=medium
+
+ * Port from Unity Mail
+
+ -- Robert Tari <robert@tari.in> Sun, 16 Aug 2020 12:28:00 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100755
index 0000000..f599e28
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/control b/debian/control
new file mode 100755
index 0000000..316fa12
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,31 @@
+Source: ayatana-webmail
+Section: mail
+Priority: optional
+Maintainer: Robert Tari <robert@tari.in>
+Build-Depends: debhelper (>= 10), dh-python, python3 (>= 3.6), python3-setuptools, python3-polib
+Standards-Version: 4.5.0
+Homepage: https://tari.in/www/software/ayatana-webmail/
+Rules-Requires-Root: no
+Vcs-Git: https://github.com/AyatanaIndicators/ayatana-webmail
+Vcs-Browser: https://github.com/AyatanaIndicators/ayatana-webmail
+X-Python3-Version: >= 3.6
+
+Package: ayatana-webmail
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}, gir1.2-messagingmenu-1.0, python3-gi, gir1.2-gtk-3.0, gir1.2-notify-0.7, python3-secretstorage (>= 1.0~), gnome-session-canberra (>= 0.28-4), python3-psutil, python3-babel, python3-urllib3
+Recommends: gir1.2-unity-5.0
+Breaks: unity-mail
+Replaces: unity-mail
+Description: Webmail notifications and actions for any desktop
+ Ayatana Webmail is an application that integrates your webmail into
+ MATE, Xfce, LXDE and other environments.
+ .
+ It displays notifications about incoming mail, shows the number of unread
+ messages and displays subjects in the Messaging Menu.
+ .
+ The Launcher item also has a quicklist that provides quick access to your
+ mail folders (configured for GMail by default). It also allows you to quickly
+ compose a new message.
+ .
+ Ayatana Webmail starts automatically, all you have to do is to enter your accounts
+ settings in a configuration dialog.
diff --git a/debian/copyright b/debian/copyright
new file mode 100755
index 0000000..fbe377e
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,32 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: Ayatana Webmail
+Upstream-Contact: Robert Tari <robert@tari.in>
+Source: https://github.com/AyatanaIndicators/ayatana-webmail
+
+Files: *
+Copyright: 2011-2014, Dmitry Shachnev <mitya57@gmail.com>
+ 2016-2020, Robert Tari <robert@tari.in>
+License: GPL-3+
+
+Files: po/*.po
+Copyright: 2011-2020, Rosetta Contributors and Canonical Ltd
+License: GPL-3+
+
+Files: debian/*
+Copyright: 2011-2014, Dmitry Shachnev <mitya57@gmail.com>
+ 2016-2020, Robert Tari <robert@tari.in>
+License: GPL-3+
+
+License: GPL-3+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 3 of the License, or
+ (at your option) any later version.
+ .
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ On Debian systems, the complete text of the GNU General Public License
+ version 3 can be found in "/usr/share/common-licenses/GPL-3".
diff --git a/debian/postinst b/debian/postinst
new file mode 100755
index 0000000..cea66d0
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,29 @@
+#!/bin/bash
+
+set -e
+
+case "$1" in
+
+ configure)
+
+ cp -n /usr/share/ayatanawebmail/indicator-messages-new.svg /usr/share/icons/hicolor/scalable/status/indicator-messages-new.svg
+ cp -n /usr/share/ayatanawebmail/indicator-messages.svg /usr/share/icons/hicolor/scalable/status/indicator-messages.svg
+ mkdir -p /usr/share/icons/matefaenza/apps/scalable
+ ln -sf /usr/share/icons/Faenza/apps/scalable/ayatanawebmail.svg /usr/share/icons/matefaenza/apps/scalable/ayatanawebmail.svg
+
+ update-icon-caches /usr/share/icons/hicolor /usr/share/icons/Faenza /usr/share/icons/matefaenza
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..004e738
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+# -*- mode: makefile; coding: utf-8 -*-
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -Rfv data/usr/share/locale
+ rm -fv ayatana-webmail.egg-info/PKG-INFO
+ rm -fv ayatana-webmail.egg-info/SOURCES.txt
+ rm -fv ayatana-webmail.egg-info/dependency_links.txt
+ rm -fv ayatana-webmail.egg-info/requires.txt
+ rm -fv ayatana-webmail.egg-info/top_level.txt
diff --git a/debian/source/format b/debian/source/format
new file mode 100755
index 0000000..9f55b2c
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0
diff --git a/debian/watch b/debian/watch
new file mode 100755
index 0000000..544180e
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
+version=3
+https://releases.ayatana-indicators.org/source/ayatana-webmail/ayatana-webmail-([0-9.]+)\.tar\.gz