aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/changelog7
-rwxr-xr-xdebian/rules32
2 files changed, 31 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 03dab92..8fd74c6 100755
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+ayatana-webmail (24.5.15) unstable; urgency=medium
+
+ * Upstream-provided Debian package for ayatana-webmail.
+ See upstream ChangeLog for recent changes.
+
+ -- Mike Gabriel <mike.gabriel@das-netzwerkteam.de> Wed, 15 May 2024 07:51:24 +0200
+
ayatana-webmail (23.12.25) unstable; urgency=medium
* Upstream-provided Debian package for ayatana-webmail.
diff --git a/debian/rules b/debian/rules
index 004e738..cd829ee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,14 +1,30 @@
#!/usr/bin/make -f
# -*- mode: makefile; coding: utf-8 -*-
+export PYBUILD_SYSTEM=distutils
+export PYBUILD_NAME=ayatana-webmail
+
%:
- dh $@ --with python3 --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild
-override_dh_auto_clean:
- dh_auto_clean
+override_dh_clean:
+ dh_clean
+ rm -Rfv .pybuild/
rm -Rfv data/usr/share/locale
- rm -fv ayatana-webmail.egg-info/PKG-INFO
- rm -fv ayatana-webmail.egg-info/SOURCES.txt
- rm -fv ayatana-webmail.egg-info/dependency_links.txt
- rm -fv ayatana-webmail.egg-info/requires.txt
- rm -fv ayatana-webmail.egg-info/top_level.txt
+ rm -fv ayatanawebmail.egg-info/PKG-INFO
+ rm -fv ayatanawebmail.egg-info/SOURCES.txt
+ rm -fv ayatanawebmail.egg-info/dependency_links.txt
+ rm -fv ayatanawebmail.egg-info/requires.txt
+ rm -fv ayatanawebmail.egg-info/top_level.txt
+ rm -f data/etc/xdg/autostart/ayatana-webmail-autostart.desktop
+ rm -f data/usr/share/applications/ayatana-webmail.desktop
+
+override_dh_fixperms:
+ dh_fixperms
+ chmod a-x debian/*/usr/share/icons/hicolor/scalable/status/ayatanawebmail-messages-new.svg
+ chmod a-x debian/*/usr/share/icons/hicolor/scalable/status/ayatanawebmail-messages.svg
+ chmod a-x debian/*/usr/share/glib-2.0/schemas/org.ayatana.webmail.gschema.xml
+ chmod a-x debian/*/usr/share/icons/hicolor/scalable/apps/ayatanawebmail.svg
+
+override_dh_installchangelogs:
+ dh_installchangelogs NEWS