aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-10-23 23:11:10 +0200
committerRobert Tari <robert@tari.in>2021-10-24 19:10:11 +0200
commit96732334e4df02eb4c704844e69a18a00acd8398 (patch)
treee411a6b57f0d961a071aa48bf70b48c5139f92e8 /CMakeLists.txt
parentc3e24c2684e5f567363dddcf29587f42b4a74512 (diff)
downloadlibayatana-appindicator-96732334e4df02eb4c704844e69a18a00acd8398.tar.gz
libayatana-appindicator-96732334e4df02eb4c704844e69a18a00acd8398.tar.bz2
libayatana-appindicator-96732334e4df02eb4c704844e69a18a00acd8398.zip
{,bindings/}CMakeLists.txt: Add switch for enabling/disabling bindings (enabled by default).
Fixes https://github.com/AyatanaIndicators/libayatana-appindicator/issues/27
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 232af6a..8cee2f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,8 @@ option(ENABLE_TESTS "Enable all tests and checks" OFF)
option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
option(ENABLE_GTKDOC "Enable building GTK documentation" OFF)
+option(ENABLE_BINDINGS_VALA "Enable Vala bindings (GTK+-3.0 and beyond only)" ON)
+option(ENABLE_BINDINGS_MONO "Enable Mono bindings" ON)
if(ENABLE_COVERAGE)
set(ENABLE_TESTS ON)
@@ -111,6 +113,8 @@ endif()
message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
message(STATUS "GTK+-3.0 build: ${FLAVOUR_GTK3}")
message(STATUS "GTK+-2.0 build: ${FLAVOUR_GTK2}")
+message(STATUS "Vala bindings: ${ENABLE_BINDINGS_VALA}")
+message(STATUS "Mono bindings: ${ENABLE_BINDINGS_MONO}")
message(STATUS "Unit tests: ${ENABLE_TESTS}")
message(STATUS "Build with -Werror: ${ENABLE_WERROR}")
message(STATUS "API Documentation: ${ENABLE_GTKDOC}")