aboutsummaryrefslogtreecommitdiff
path: root/bindings/python/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-07-18 17:09:55 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-07-18 17:09:55 +0200
commit8c4c6dbad48239d6bbe433d886a294a52f95fee5 (patch)
tree40824857d3d166d66caec4c03889d3b9826d50e2 /bindings/python/Makefile.am
parenteb5ffbb18bfb7a03f9e6c4f5dba7ab4e66901d40 (diff)
downloadlibayatana-appindicator-8c4c6dbad48239d6bbe433d886a294a52f95fee5.tar.gz
libayatana-appindicator-8c4c6dbad48239d6bbe433d886a294a52f95fee5.tar.bz2
libayatana-appindicator-8c4c6dbad48239d6bbe433d886a294a52f95fee5.zip
bindings/pyton: Drop Python2/Gtk-2 bindings.
Diffstat (limited to 'bindings/python/Makefile.am')
-rw-r--r--bindings/python/Makefile.am40
1 files changed, 0 insertions, 40 deletions
diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
deleted file mode 100644
index 32d43a3..0000000
--- a/bindings/python/Makefile.am
+++ /dev/null
@@ -1,40 +0,0 @@
-defsdir = $(datadir)/pygtk/2.0/defs
-defs_DATA = ayatana_appindicator.defs
-
-#CFLAGS = -Wall -Werror
-INCLUDES = \
- -I$(top_srcdir)/src \
- -DG_LOG_DOMAIN=\"ayatana-appindicator-python\" \
- -DDATADIR=\"$(datadir)\" \
- -DLIBDIR=\"$(libdir)\" \
- $(APPINDICATOR_PYTHON_CFLAGS) \
- $(PYTHON_INCLUDES)
-
-pkgpythondir = $(pyexecdir)
-pkgpyexecdir = $(pyexecdir)
-
-pkgappindicatordir = $(pkgpythondir)/ayatana_appindicator
-pkgappindicator_PYTHON = __init__.py
-
-appindicatordir = $(pkgpyexecdir)/ayatana_appindicator
-appindicator_LTLIBRARIES = _ayatana_appindicator.la
-
-_ayatana_appindicator_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_ayatana_appindicator
-_ayatana_appindicator_la_LIBADD = $(APPINDICATOR_PYTHON_LIBS) -L$(top_builddir)/src/.libs -layatana-appindicator
-_ayatana_appindicator_la_SOURCES = ayatana_appindicatormodule.c
-nodist__ayatana_appindicator_la_SOURCES = ayatana_appindicator.c
-
-CLEANFILES = ayatana_appindicator.c
-DISTCLEANFILES = Makefile.in
-EXTRA_DIST = ayatana_appindicator.override.in appindicator-arg-types.py $(defs_DATA)
-ayatana_appindicator.c: $(defs_DATA) ayatana_appindicator.override
-
-%.c: %.defs
- ($(PYGTK_CODEGEN) \
- --register $(PYGTK_DEFSDIR)/gtk-types.defs \
- --register $(PYGTK_DEFSDIR)/gdk-types.defs \
- --load-types $(srcdir)/appindicator-arg-types.py \
- --override $*.override \
- --prefix py$* $(srcdir)/$*.defs) > gen-$*.c \
- && cp gen-$*.c $*.c \
- && rm -f gen-$*.c