aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-01 21:42:21 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-01 21:42:21 +0200
commit1defcc371c6e286d4396dca2c4018ba1f3d9be59 (patch)
tree077b74b55008a005d3442088ba9be1fa4b315b51 /debian/rules
parentc43a76e643ab930725d20d306bc3ca5e7874eebe (diff)
parent6173997abf4dadb72b3ac749aac57d4251b28ca7 (diff)
downloadlibayatana-appindicator-1defcc371c6e286d4396dca2c4018ba1f3d9be59.tar.gz
libayatana-appindicator-1defcc371c6e286d4396dca2c4018ba1f3d9be59.tar.bz2
libayatana-appindicator-1defcc371c6e286d4396dca2c4018ba1f3d9be59.zip
Merge branch 'pr/fix-unit-tests'
Attribute GH PR #19: https://github.com/AyatanaIndicators/libayatana-appindicator/pull/19
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 8ad670f..d4c149e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -64,11 +64,11 @@ override_dh_install:
override_dh_auto_test: $(FLAVORS:%=dotest-%)
dotest-%:
- mkdir -p $(CURDIR)/debian/tmphome/.cache
- export HOME=$(CURDIR)/debian/tmphome && export XDG_CACHE_HOME=$(CURDIR)/debian/tmphome/.cache && dh_auto_test --builddirectory=build/$* -- || true
+ mkdir -p $(CURDIR)/debian/tmphome-$*
+ export HOME=$(CURDIR)/debian/tmphome-$* && dh_auto_test --no-parallel --builddirectory=build/$*
# View test's log file for better debugging of problems when built in clean chroots.
if [ -e build/$*/tests/test-suite.log ]; then cat build/$*/tests/test-suite.log; fi
- rm -Rf $(CURDIR)/debian/tmphome
+ rm -Rf $(CURDIR)/debian/tmphome-$*
override_dh_auto_clean:
dh_auto_clean