aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-11-11 16:32:41 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-11-11 16:32:49 +0100
commit3dbc56b6acfb9a70e91615d895e7a0fa811fe4fc (patch)
tree01fa393ff647223da2876f30fbbcf2b2e3fb04bf /debian/rules
parent8f3e225150c2e8970b1922351a7fdca02e826272 (diff)
downloadlibayatana-appindicator-3dbc56b6acfb9a70e91615d895e7a0fa811fe4fc.tar.gz
libayatana-appindicator-3dbc56b6acfb9a70e91615d895e7a0fa811fe4fc.tar.bz2
libayatana-appindicator-3dbc56b6acfb9a70e91615d895e7a0fa811fe4fc.zip
debian/rules: Use instead of `pwd`.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 6 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 057d717..426bc0d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -75,23 +75,23 @@ override_dh_install:
override_dh_auto_test: $(FLAVORS:%=dotest-%)
dotest-%:
- mkdir -p `pwd`/debian/tmphome
- HOME=`pwd`/debian/tmphome dh_auto_test dh_auto_test --builddirectory=build/$* -- || true
+ mkdir -p $(CURDIR)/debian/tmphome
+ HOME=$(CURDIR)/debian/tmphome dh_auto_test dh_auto_test --builddirectory=build/$* -- || true
# View test's log file for better debugging of problems when built in clean chroots.
if [ -e build/$*/tests/test-suite.log ]; then cat build/$*/tests/test-suite.log; fi
- rm -Rf `pwd`/debian/tmphome
+ rm -Rf $(CURDIR)/debian/tmphome
dotest-gtk2: $(PY_VERSIONS:%=dotestgtk2-%)
# GTK2 flavor test was run on a per-python-version basis.
dotestgtk2-%:
- mkdir -p `pwd`/debian/tmphome
+ mkdir -p $(CURDIR)/debian/tmphome
PYTHON=`which $*` \
- HOME=`pwd`/debian/tmphome dh_auto_test --builddirectory=build/gtk2 -- || true
+ HOME=$(CURDIR)/debian/tmphome dh_auto_test --builddirectory=build/gtk2 -- || true
# View test's log file for better debugging of problems when built in clean chroots.
if [ -e build/gtk2/tests/test-suite.log ]; then cat build/gtk2/tests/test-suite.log; fi
- rm -Rf `pwd`/debian/tmphome
+ rm -Rf $(CURDIR)/debian/tmphome
override_dh_auto_clean:
dh_auto_clean