aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorunknown <evgeni@debian.org>2012-05-22 08:17:53 +0200
committerunknown <evgeni@debian.org>2012-05-22 08:17:53 +0200
commit8d0330b70fdf7a36185cec6451c7d5094f4a1ff0 (patch)
tree7157c61fa1f504e766d7e6b283ff784b6e78d2e3 /debian/rules
parent27eb63cac2b504aab8baf568ba87ae9271c291ff (diff)
downloadlibayatana-appindicator-8d0330b70fdf7a36185cec6451c7d5094f4a1ff0.tar.gz
libayatana-appindicator-8d0330b70fdf7a36185cec6451c7d5094f4a1ff0.tar.bz2
libayatana-appindicator-8d0330b70fdf7a36185cec6451c7d5094f4a1ff0.zip
use autoreconf.mk instead of calling dh_autoreconf by hand
- fixes FTBFS when there are multiple Python versions (dh_autoreconf would be called multiple times in this case, which isn't allowed) - properly cleans autoreconf'ed files in the clean target - patchsys-quilt.mk needs to be included *before* autoreconf.mk or debhelper will leave uncleaned files in debian/, leading to E: libappindicator source: temporary-debhelper-file python-appindicator.debhelper.log and 9 others from lintian
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 65a2860..666d331 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,10 +8,11 @@ PY_VERSIONS = $(shell pyversions --requested debian/control)
export MONO_SHARED_DIR=$(CURDIR)
export CSC=/usr/bin/mono-csc
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/autoreconf.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
include /usr/share/cdbs/1/rules/utils.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
API_VERSION = 0.1
@@ -20,7 +21,6 @@ API_VERSION = 0.1
DEB_CONFIGURE_EXTRA_FLAGS += --disable-scrollkeeper --enable-gtk-doc --enable-introspection
configure-stamp-%:
- dh_autoreconf
mkdir build-$*
cd build-$* && PYTHON=`which $*` \
$(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) --srcdir=..