aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2013-12-19 17:34:38 +0000
committerTarmac <Unknown>2013-12-19 17:34:38 +0000
commit25762ad8307f81c09307419d48fdfb94bdc396ae (patch)
treee4b3c053e75d0df5c375e428499ac5e38de92b34 /debian
parent65bc7f80becdd2f2e01be4e14a7d2d960615cdb9 (diff)
parent52c50b3f9b571f44dc1f255365dc5c90ab2c6730 (diff)
downloadlibayatana-appindicator-25762ad8307f81c09307419d48fdfb94bdc396ae.tar.gz
libayatana-appindicator-25762ad8307f81c09307419d48fdfb94bdc396ae.tar.bz2
libayatana-appindicator-25762ad8307f81c09307419d48fdfb94bdc396ae.zip
Fix build failures on trusty. Fixes: https://bugs.launchpad.net/bugs/1262655.
Approved by PS Jenkins bot, Charles Kerr.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control10
-rwxr-xr-xdebian/rules2
3 files changed, 14 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 1061624..63c650e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+libappindicator (12.10.1+13.10.20130920-0ubuntu3) trusty; urgency=medium
+
+ * Build with -Wno-error=deprecated-declarations.
+ * Don't build the mono bindings on ppc64el, not available.
+ * Disable building the example, vala build error.
+
+ -- Matthias Klose <doko@ubuntu.com> Thu, 19 Dec 2013 13:50:03 +0100
+
libappindicator (12.10.1+13.10.20130920-0ubuntu2) saucy; urgency=low
* Don't build the mono bindings on AArch64, not available.
diff --git a/debian/control b/debian/control
index 1d9b829..30c1b62 100644
--- a/debian/control
+++ b/debian/control
@@ -7,22 +7,22 @@ Build-Depends: debhelper (>= 9),
dh-autoreconf,
python-all-dev,
at-spi2-core,
- cli-common-dev (>= 0.5.7) [!arm64],
+ cli-common-dev (>= 0.5.7) [!arm64 !ppc64el],
gobject-introspection,
intltool,
gtk-doc-tools,
libxml2-utils,
- libnunit-cil-dev [!arm64],
+ libnunit-cil-dev [!arm64 !ppc64el],
dbus-test-runner,
xvfb,
valac,
- mono-devel (>= 2.4.3) [!arm64],
+ mono-devel (>= 2.4.3) [!arm64 !ppc64el],
libglib2.0-dev (>= 2.35.4),
libgtk-3-dev (>= 2.91.3),
libgtk2.0-dev (>= 2.12.0),
python-gtk2-dev,
- gtk-sharp2-gapi [!arm64],
- libgtk2.0-cil-dev [!arm64],
+ gtk-sharp2-gapi [!arm64 !ppc64el],
+ libgtk2.0-cil-dev [!arm64 !ppc64el],
libdbus-glib-1-dev (>= 0.82),
libindicator-dev (>= 0.3.90),
libindicator3-dev (>= 0.3.90),
diff --git a/debian/rules b/debian/rules
index 9df0c58..4fe4e6b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,7 @@ API_VERSION = 0.1
DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
CONFIGURE_COMMON_FLAGS = --disable-scrollkeeper --enable-introspection
-ifneq (,$(filter $(DEB_HOST_ARCH),arm64))
+ifneq (,$(filter $(DEB_HOST_ARCH),arm64 ppc64el))
CONFIGURE_COMMON_FLAGS += --disable-mono-test
else
dh_extra_args = ,cli